18 de juliol de 2008

Algunes extensions deixen de funcionar amb el Firefox 3.0.1

Amb l'actualització ahir del Firefox 3.0 a la versió 3.0.1, alguns usuaris s'han trobat que certes extensions no funcionen. Tot i que es tracta d'una minoria és un problema de fàcil sol·lució, però que requereix la participació dels desenvolupadors de les extensions.

Les extensions, en l'arxiu comprimit .xpi en el que venen hi ha uns fitxers de text on s'indica, entre altres, amb quines versions del Firefox és compatible. El problema es deu al fet que alguns desenvolupadors, a l'hora de posar l'interval de versions, van posar que l'extensió era compatible des del Firefox 2.0 al 3.0. Per tant, el Firefox interpreta que la versió 3.0 és el límit màxim i que no funcionarà amb cap versió posterior, per exemple la 3.0.1.

Per sol·lucionar-ho, només cal que els desenvolupadors substitueixin el valor 3.0 pel 3.0.*. Si alguna de les extensions que utilitzeu habitualment tenen aquest problema, el millor que podeu fer és posar-vos en contacte amb els desenvolupadors.

"Firefox 3.0.1 and add-on compatibility" - Basil’s Bodacious Blog
Actualitzat (20:40 - 18/07/08): Asa Dotzler ha escrit una entrada al seu bloc on assegura que Mozilla està contactant amb els desenvolupadors de les extensions, i que aquest possible problema ja feia mesos que es recordava als desenvolupadors. Diu que si trobem alguna extensió que no funciona amb el Firefox 3.0.1 (però funcionava amb el 3.0) ens posem en contacte amb ell i ajduarà als desenvolupadors.

Cap comentari:

Publica un comentari a l'entrada